.com.unity Forums

.com.unity Forums (http://forum.shrapnelgames.com/index.php)
-   Weird Worlds: Return to Infinite Space (http://forum.shrapnelgames.com/forumdisplay.php?f=125)
-   -   bug alert? (http://forum.shrapnelgames.com/showthread.php?t=26957)

Davin December 8th, 2005 05:53 AM

bug alert?
 
I just tried to equip a damaged item. When I hovered over the slot, my cursor turned into a wrench with the item attached to it. Clicked, crashed.

I'll try to replicate the circumstances...

Puke December 8th, 2005 02:20 PM

Re: bug alert?
 
how did you unequip the damaged item, in the first place?

Davin December 8th, 2005 04:59 PM

Re: bug alert?
 
Swapped it with another item.

Puke December 15th, 2005 04:06 PM

Re: bug alert?
 
i tried to do this a couple times, and could not re-create it.

It has always been with damaged weapons, but when i attempt to swap a damaged weapon with one from cargo, it changes to the wrench icon and repairs the item instead. a second click will swap the two repaired items.

I'm not doubting that this happened to you, just adding that it does not seem to happen all the time. maybe its just with certain items?

Davin December 22nd, 2005 07:37 AM

Re: bug alert?
 
I think what actually happened was that I had a cheap combat computer (the theory works with any SYST type) in there and it got damaged, I put a more advanced one into an empty hardpoint (successfully avoiding the need to click on it to swap it) and the damaged one obviously came out.

So the bug required a slightly more complex set-up than I thought, but I assure you it's there http://forum.shrapnelgames.com/images/smilies/wink.gif

What I imagine the actual cause of the crash to be is the engine attempting to repair an object that doesn't exist (the one in the empty hardpoint, instead of the one you're holding with the cursor) and throwing up as a result.
Just my two cents.

rocky8311 December 22nd, 2005 05:54 PM

Re: bug alert?
 
I just had my WW inexplicably close. I had a Signal Projector picked up with the cursor and I pressed the '2' key to switch over to my new Muktian Corvette and the program just...closed. No error report or anything. I'm running the new patch.

Fingers December 23rd, 2005 04:26 AM

Re: bug alert?
 
Davin: Interesting, sounds like you've got something there.

Rocky: Hm, that'd definitely be a bug. Does this happen reliably (like whenever you have two ships)?

rocky8311 December 23rd, 2005 02:12 PM

Re: bug alert?
 
It's the only time it's ever happened but I'll speak up if it does again. WW is a very nonbuggy game IMO, you should be proud.

rocky8311 December 23rd, 2005 03:09 PM

Re: bug alert?
 
Alright I said I would, so here I am. The same bug just happened in a different way. I was holding a Neptunium Railgun with the cursor and pressed '2' to switch from my Terran Frigate to Muktian Fighter and the game abruptly closed without any kind of Microsoft error message.

Probably a coincidence that it involved a Muktian ship both times. It's when I pressed the '2', or at least the act of switching ships.

PERHAPS it is that both times I pulled something off the Lead ship and went to put it on another without putting it down in the hold first? That is my best guess, b/c that is what I was doing both times; moving something directly between the ships while using the numbers as hotkeys.

rocky8311 December 23rd, 2005 03:11 PM

Re: bug alert?
 
That or maybe it crashed b/c it just didn't like me using both hotkeys and having something in the "grip" of the mouse cursor at the same time. It might have had nothing to do with me moving something directly between two ships. I'll try to replicate this.

rocky8311 December 23rd, 2005 05:02 PM

Re: bug alert?
 
And it's happened again.

New idea: it might have to do with causing two sounds to play to close together: the sound for removing the item from one ship and the sound of switching to another.

The use of the hotkey might be what makes it easier to trigger them so close together.

BTW, this didn't happen to me before the patch.

rocky8311 December 23rd, 2005 05:39 PM

Re: bug alert?
 
Update...I don't even have to be holding anything for it to crash when I use the hotkeys on the galaxy map to switch between ship views.

That, or it's a procondition that I'm doing well in the game before it crashes every time. >:[

Fingers December 23rd, 2005 05:51 PM

Re: bug alert?
 
Confirmed the bug, this seems to have something to do with the Muktian ship as switching to any other ship works fine. I'll investigate.

rocky8311 December 23rd, 2005 07:16 PM

Re: bug alert?
 
It just happened to me with no Muktian ships in my fleet. One time I deliberately tried to trigger it and I couldn't get it to happen. But it just happened to me again. I didn't have an item picked up, but I had just installed one and the sound for installing a system on a ship was still playing as I pressed a hotkey to switch to another ship (I think from ship '3' to ship '1' or the other way around. '3' was the Bloodfang and '1' the Pirate Corvette this time.)

Fingers December 23rd, 2005 07:56 PM

Re: bug alert?
 
OK, found the actual cause. It has to do with the mouseover state... If you're pointing at a hardpoint that has an item, switch ships, and the next ship has an empty hardpoint of the same index it'll try to display the name of a system in the empty slot and it crashes. I'm surprised this didn't come up earlier as the bug must've been there for a long time.

Foosnark December 25th, 2005 12:08 AM

Re: bug alert?
 
Just ran into this myself, glad to see it's no longer a mystery.

ImUrOBGYN December 27th, 2005 01:54 PM

Re: bug alert?
 
I've been having the same problem since the patch. Never a single crash previous to it. If I remember correctly, I was always in the process of doing something with the ships, ie; adding or taking items aways, switching between them, etc. Sometimes I wonder if it's because of hotkeying to fast, but it seems rocky tried that and it's not the case. It's always deep into a game it seems (I like the large maps) and it'd driving me crazy! Ahh... addictions...

Fingers December 28th, 2005 04:19 PM

Re: bug alert?
 
This was fixed in the 1.11 patch a few days ago...

ImUrOBGYN December 28th, 2005 07:46 PM

Re: bug alert?
 
Yes, I just saw that before coming back here for your reply. Thx! I'm installin it now.


All times are GMT -4. The time now is 06:12 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, Shrapnel Games, Inc. - All Rights Reserved.