.com.unity Forums

.com.unity Forums (http://forum.shrapnelgames.com/index.php)
-   War Plan Pacific (http://forum.shrapnelgames.com/forumdisplay.php?f=209)
-   -   Vista SP1 - Cannot Start (http://forum.shrapnelgames.com/showthread.php?t=41689)

kwverdon December 22nd, 2008 11:24 AM

Vista SP1 - Cannot Start
 
Has anyone been able to get WPP running on Vista SP1? When I try to run WPP I get an error "WPP has stopped working" with the only option to close. I've tried modifying the shortcut so that it tries to run in XP comnpatibility mode or with Admin rights but neither has worked. This is on my Dell Studio 17 Laptop. This would be the perfect laptop game if I could just get it working :mad:

Thanks,

Kevin

OTGamer December 22nd, 2008 11:54 AM

Re: Vista SP1 - Cannot Start
 
Check the file permissions of the "Program Files" directory and make sure those permissions are full under the account you are running.

My experience is with XP. I've noticed even Admin accounts sometimes wind up with less than full access to the "Program Files" directory. If I run WPP on an Admin account that does not have full "Program Files" privileges, it will terminate when I try to begin a scenario. If I give the account full privileges (I have to do this explicitly for the Program Files folder), all is well. Perhaps something similar is going on with Vista? This is just a possible solution; it is probably something else. But it won't hurt to check to be sure.

And while you're at it, make sure the KE Studios folder has full privileges as well.

Annette December 22nd, 2008 03:22 PM

Re: Vista SP1 - Cannot Start
 
Please try please running the following from the folder where you installed the file:



· vcredist_x86.exe

· xnafx20_redist.msi

· direct\DXSetup.exe

Jankee December 22nd, 2008 09:09 PM

Re: Vista SP1 - Cannot Start
 
It runs on my 64bit Vista SP1.

kwverdon December 23rd, 2008 12:37 AM

Re: Vista SP1 - Cannot Start
 
It finally works! I coppied the DXsetup folder to the folder where the program is installed and ran DXsetup and now it works!

thanks,

Kevin

ratherbegliding January 9th, 2009 02:56 AM

Re: Vista SP1 - Cannot Start
 
Hi there,

OK so I appreciate I'm probably missing something really obvious here, but the demo refuses to run on my machine (Vista 64 bit).

I installed as normal, then copied:

vcredist_x86.exe

and

xnafx20_redist.msi

into the installation directory and ran them.

Then copied the whole DirectX folder into the installation directory (so it appears next to the 'Content' directory) and then ran DXsetup.exe

All three installations seem to work ok - but the demo still fails - I get the 'WPP has stopped working' box.

What am I doing wrong??

Thx
RBG

ratherbegliding January 9th, 2009 03:50 AM

Re: Vista SP1 - Cannot Start
 
I take it all back!

Re-booted my machine and it started first time.

IT is certainly a black art sometimes.

RBG


All times are GMT -4. The time now is 07:27 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, Shrapnel Games, Inc. - All Rights Reserved.