.com.unity Forums

.com.unity Forums (http://forum.shrapnelgames.com/index.php)
-   WinSPWW2 (http://forum.shrapnelgames.com/forumdisplay.php?f=139)
-   -   Making winSPWW2 work on Linux, using WINE (http://forum.shrapnelgames.com/showthread.php?t=44420)

nuNce November 29th, 2009 11:57 AM

After some days of yelling at my PC screen for the game not working correctly, I found out how to do it. So I'd like to share with you some tips and suggestions.

First, what I'm using. I'm running the game with wine 1.1.31 under Ubuntu 9.10 Karmic Koala. This last version has solved many problem I had with the previous one. I'm using Windows XP emulation.

Audio glitches

Without changing any settings my audio was choppy and didn't play very well. I tried the Esound driver, but it kept going out of sync with the graphics, so I instead switched to ALSA. I've turned hardware acceleration off (driver emulation) but I kept maximum sound quality.

No audio and no interface issue

This was getting me mad the most. At some point, the audio playback gone mute, and the interface on the right would disappear. You may be lucky enough to get it back just in time for a save, after which the game would freeze and crash. Seems like this is caused by overlapping sounds, due to fast graphics execution. I have solved this by setting the graphics delay to 40 in the launcher, so the game plays at a decent speed (I'd say normal) and my game hasn't crashed since then. Also disabling the mouse click helps a lot.
Help may have come from a registry key I have entered to enable direct access to the soundcard. To do so simply open the terminal and input "wine regedit". Then you must find out the key HKEY_CURRENT_USER//Software//Wine//DirectSound and right click in the right screen. Choose "New/String" name it UseDirectHW, and then as value put y.

Streched window

You may start your game in windowed mode, but then you notice that your gamescreen is short. Your width is right, but the height is 200-300px. This is often caused by using a resolution with a height larger than the actual screen height. Raise your screen's resolution or lower the game's one.

Full CD version launcher not recognized

This applies only to CD version owners!

You launch your game by double clicking the .exe but when you try to access to the enhanced functions they are greyed out (resolution higher than 800*600) or a message tells you they are available only to CD owners. Man! This may get you mad. As simple as it can be you need only to launch the game from terminal with

Quote:

wine ~/.wine/drive_c/Program Files/Shrapnel Games/The Camo Workshop/WinSPWW2/WW2GameOptions.exe
You can write yourself a bash script to put a Desktop link too. Open a text editor and input the following.

Quote:

#!/bin/bash
cd $HOME'/.wine/drive_c/Program Files/Shrapnel Games/The Camo Workshop/WinSPWW2'
WINEDEBUG=-all wine WW2GameOptions.exe
Please check the directory to your game is correct (should be if you didn't change it during install).

Now save the file as winsp and open the terminal. Browse to the directory where you saved the file and digit these commands:

Quote:

chmod +x winsp
sudo cp winsp /usr/bin
Now you can make a link on the desktop by creating a new launcher and assigning it the command winsp.

I hope it helps!

nuNce November 29th, 2009 12:02 PM

Re: Maxing winSPWW2 working on Linux, using WINE
 
Whoops! Can a mod change the thread title to "Making winSPWW2..." and then delete this post? Thanks! :)

junk2drive December 4th, 2009 08:56 PM

Re: Making winSPWW2 work on Linux, using WINE
 
I'm using Lucid 10.01 alpha with Wine 1.1.33 beta and CD version.
Game menu comes up fine, allows me to select 1024x768. But windowed or full screen I get a box 1024 wide and about 200 high and I can't select anything. 800x600 windowed works fine.

nuNce December 5th, 2009 03:26 AM

Re: Making winSPWW2 work on Linux, using WINE
 
AFAIK this depends on your screen resolution If you choose a height or a width greater than those of your display you get a streched window. I'll add this to the first post. Tell me what screen resolution you use. I have 1280*800 and I can't go past 1024*768.

junk2drive December 6th, 2009 12:09 PM

Re: Making winSPWW2 work on Linux, using WINE
 
I have a CRT set at 1024x768. The game menu lists several choices.
I tried editing the .ini to add a line for height but that didn't work.

nuNce December 6th, 2009 12:45 PM

Re: Making winSPWW2 work on Linux, using WINE
 
The menu will always list all possibilieties. Since your screen's height is 768, when you start the game at the same resolution the window's height will be 768+the border and the titlebar, so it will overflow. If you can try setting the screen resulution to a higher value, just for testing purposes.

junk2drive December 8th, 2009 10:49 PM

Re: Making winSPWW2 work on Linux, using WINE
 
I tried with and without virtual desktop and all the res above 1024, still no luck.
I'm installing 1.1.34 now and will check again.

nuNce December 9th, 2009 07:47 AM

Re: Making winSPWW2 work on Linux, using WINE
 
It's not a case of virtual desktop. I meant you should have tried changing your actual desktop resolution.

junk2drive December 9th, 2009 09:48 AM

Re: Making winSPWW2 work on Linux, using WINE
 
It took me years to go from 800x600 to 1024x768, lol. I'm old and it is hard enough to see little icons.

1.1.34 did not change it.

1280x1024 is my only other choice, didn't help either.

nuNce December 9th, 2009 12:29 PM

Re: Making winSPWW2 work on Linux, using WINE
 
You may change resolution only when you play winSPww2, or you may buy a bigger monitor! :D If you find it difficult to read text when @ 1280 you may change your DPI, so text would look bigger.

To do this go (I'm assuming you are using ubuntu) System/Preferences/Looks/Characters (I'm guessing it, I have an Italian language install) then Details, and you can raise your DPI value.


All times are GMT -4. The time now is 03:47 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, Shrapnel Games, Inc. - All Rights Reserved.