.com.unity Forums
  The Official e-Store of Shrapnel Games

This Month's Specials

The Star & the Crescent- Save $8.00
winSPWW2- Save $5.00

   







Go Back   .com.unity Forums > Shrapnel Community > Space Empires: Starfury

Reply
 
Thread Tools Display Modes
  #1  
Old May 20th, 2008, 11:39 AM

Sole33 Sole33 is offline
Private
 
Join Date: May 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Sole33 is on a distinguished road
Default crash while trying to add a ship mod

i was wondering if someone here would recognize if maybe im doing something wrong, or if its just a general problem i don't know about.

i've been trying to add a ship from se5 into star fury, its the hiiagrin destroyer from homeworld, but someone thankfully made a homeworld set for se5. as far as i can tell i've done everything right, so im hoping maybe its a complication with .x files for the two different games or maybe this particular set?

what happens is an access violation in starfury.exe when i get to the ship selection just after choosing campaign difficulty, particularly when i click on Terran Destroyer Mark I in the menu.

what i have done:
-i made a component layout with slot modder and added the exported text to Main_ComponentConfigurationSlotsPlayer.txt
-i created the 3 bmp files, shield and the 2 portrait pics, all the correct sizes
-copied the .x file to /XFiles
-eventually moved every single texture from the se5 hiiagrin folder to /images when i was thinking maybe the model is not finding a texture or something
-added a section in SpaceObjects_XFiles.txt
-added a section in Main_StartingPlayerShips.txt then when that didn't work i tried adding it to Main_PurchaseShipsPlayer.txt

As far as i can tell everything points in the right direction, i played around with a few other troublesome things and it seems if you make an error in the .txt files it doesn't cause the game to crash like that most of the time, just a nasty error message.

im at a loss for wtf is wrong, has anyone else had experience with game crashes at the ship selection/captains name screen?
Reply With Quote
  #2  
Old May 21st, 2008, 03:45 AM

rstaats10 rstaats10 is offline
Corporal
 
Join Date: Jul 2007
Posts: 111
Thanks: 0
Thanked 4 Times in 2 Posts
rstaats10 is on a distinguished road
Default Re: crash while trying to add a ship mod

It sounds like you have done your homework. It could be many things. However, most of my past crashing errors have been due to an entry error in the componentconfigurationslotsplayer file. If you could create a zip file and add the files for this ship as an attatchment in this post, I will take a look at it. I have converted many, many SEV ships to SF. (about 50) Sometimes it can be something as simple as a spacing error, spelling error, or can be something else that was overlooked.

Are you playing in windowed mode? (SF>Setup>Video Mode>Windowed)
Windowed mode will generate an error report for most errors. Componentconfigurationslots errors will not always show up in the detail though; just a crash when trying to load the ship.
Reply With Quote
  #3  
Old May 21st, 2008, 01:50 PM

Sole33 Sole33 is offline
Private
 
Join Date: May 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Sole33 is on a distinguished road
Default Re: crash while trying to add a ship mod

ok, let me know if i didn't include anything in the archive, that could be the problem or maybe something i forgot.

Files:
Hiigaran_Battleship.x
Main_ComponentConfigurationSlotsPlayer.txt
Main_PurchaseShipsPlayer.txt
SpaceObjects_XFiles.txt
the 3 portrait and shield *.bmp files
and 5 *.bmp files that are used as materials in the model

originally i wasn't using windowed mode, but switched to it to try and resolve the issue, the game still gives no error messages, just crashes.

... i couldn't find where to add attachments to this, maybe because its a quick reply? but i'll just throw them on a hosting website..
http://www.mediafire.com/?goxsdig4cg4
Reply With Quote
  #4  
Old May 21st, 2008, 02:15 PM

Sole33 Sole33 is offline
Private
 
Join Date: May 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Sole33 is on a distinguished road
Default Re: crash while trying to add a ship mod

hmm, interesting, i just changed some names around before i made the *.zip file because i didn't want you to see the dorky name i made for the ship, i figured i would give it a shot at trying to fix it again, and this time i got an error message just before the crash, so i switched to windowed mode and copied it.

The error pointed at SpaceObjects_XFiles.txt and said this:
Could not find field "Name" in record 1.
Could not find field "XFile" in record 1.
Could not find field "Override Texture Filename" in record 1.
Could not find field "Base Model Radius" in record 1.
Could not find field "Starting Rotate X" in record 1.
Could not find field "Starting Rotate Y" in record 1.
Could not find field "Starting Rotate Z" in record 1.
Could not find field "Starting Scale X" in record 1.
Could not find field "Starting Scale Y" in record 1.
Could not find field "Starting Scale Z" in record 1.
Could not find field "Starting Position Offset X" in record 1.
Could not find field "Starting Position Offset Y" in record 1.
Could not find field "Starting Position Offset Z" in record 1.
Could not find field "Continual Rotation Vector X" in record 1.
Could not find field "Continual Rotation Vector Y" in record 1.
Could not find field "Continual Rotation Vector Z" in record 1.
Could not find field "Continual Rotation Speed" in record 1.
Could not find field "Star Glow Color" in record 1.
Could not find field "Firing Flash Color" in record 1.
Could not find field "Explosion Effect" in record 1.
Could not find field "Explosion Center Color" in record 1.
Could not find field "Explosion Radius" in record 1.
Could not find field "Number Of Firing Points" in record 1.
Could not find field "Number Of Engine Points" in record 1.
Could not find field "Number Of Lights" in record 1.

considering this happens when i click on terran destroyer on the menu before the game even starts (i put my ship in Main_PurchaseShipsPlayer.txt), could it be that the first entry in SpaceObjects_XFiles.txt has to be the terran ships? or behind the // marks, i thought they were just comment marks but does the game read them as some kind of headers for the different groups of ships? also, i place the text for my ship at the top of the list every time, is there a certain place you have to put them?
Reply With Quote
  #5  
Old May 21st, 2008, 02:47 PM

Sole33 Sole33 is offline
Private
 
Join Date: May 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Sole33 is on a distinguished road
Default Re: crash while trying to add a ship mod

ok, i acually fixed it *whew*, now i only have to set the starting rotation so my ship looks like its going the right direction, as well as scale it up a litte, quick question: the rotation does not seem to depend on a 360 degree set of numbers i.e. 90, 180 X Y Z and whatnot, when i set X to 90 and Z to 180, the ship appears diagonally downwards, a setting of 90 or 180 shouldn't produce any diagonal directions by degrees?

for anyone that has these same problems that i had here are the error messages and the fixes:

*@ ship selection before game, i now know that 'record 1' means the first entry in the text file the error is pointing to, something so obvious i should have figured it out earlier
Could not find field "Name" in record 1.
Could not find field "XFile" in record 1.
Could not find field "Override Texture Filename" in record 1.
Could not find field "Base Model Radius" in record 1.
Could not find field "Starting Rotate X" in record 1.
Could not find field "Starting Rotate Y" in record 1.
Could not find field "Starting Rotate Z" in record 1.
Could not find field "Starting Scale X" in record 1.
Could not find field "Starting Scale Y" in record 1.
Could not find field "Starting Scale Z" in record 1.
Could not find field "Starting Position Offset X" in record 1.
Could not find field "Starting Position Offset Y" in record 1.
Could not find field "Starting Position Offset Z" in record 1.
Could not find field "Continual Rotation Vector X" in record 1.
Could not find field "Continual Rotation Vector Y" in record 1.
Could not find field "Continual Rotation Vector Z" in record 1.
Could not find field "Continual Rotation Speed" in record 1.
Could not find field "Star Glow Color" in record 1.
Could not find field "Firing Flash Color" in record 1.
Could not find field "Explosion Effect" in record 1.
Could not find field "Explosion Center Color" in record 1.
Could not find field "Explosion Radius" in record 1.
Could not find field "Number Of Firing Points" in record 1.
Could not find field "Number Of Engine Points" in record 1.
Could not find field "Number Of Lights" in record 1.
fix: removed //custom and //stock tags from SpaceObjects_XFiles.txt file and placed my ship as the last entry before *END*

*@ very start of game
Could not find field "Layout Name" in record 1.
Could not find field "Number Of Slots" in record 1.
Could not find field "Layout Name" in record "Hiigaran Battleship Layout".
Could not find field "Number Of Slots" in record "Hiigaran Battleship Layout".
fix: removed //custom and //stock tags from Main_ComponentConfigurationSlotsPlayer.txt and place my ship as the last entry once again

@ entering the ship dealer
Could not find field "Ship Class Name" in record 1.
Could not find field "Ship Class Name" in record "Hiigaran Battleship".
fix: same as above with Main_PurchaseShipsPlayer.txt

maybe this will help anyone who stills plays/mods this game
Reply With Quote
  #6  
Old May 21st, 2008, 08:22 PM
Suicide Junkie's Avatar
Suicide Junkie Suicide Junkie is offline
Shrapnel Fanatic
 
Join Date: Feb 2001
Location: Waterloo, Ontario, Canada
Posts: 11,451
Thanks: 1
Thanked 4 Times in 4 Posts
Suicide Junkie is on a distinguished road
Default Re: crash while trying to add a ship mod

Try using angles measured in radians rather than degrees.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:47 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, Shrapnel Games, Inc. - All Rights Reserved.