.com.unity Forums

.com.unity Forums (http://forum.shrapnelgames.com/index.php)
-   Weird Worlds: Return to Infinite Space (http://forum.shrapnelgames.com/forumdisplay.php?f=125)
-   -   bug alert? (http://forum.shrapnelgames.com/showthread.php?t=26957)

Davin December 8th, 2005 05:53 AM

bug alert?
I just tried to equip a damaged item. When I hovered over the slot, my cursor turned into a wrench with the item attached to it. Clicked, crashed.

I'll try to replicate the circumstances...

Puke December 8th, 2005 02:20 PM

Re: bug alert?
how did you unequip the damaged item, in the first place?

Davin December 8th, 2005 04:59 PM

Re: bug alert?
Swapped it with another item.

Puke December 15th, 2005 04:06 PM

Re: bug alert?
i tried to do this a couple times, and could not re-create it.

It has always been with damaged weapons, but when i attempt to swap a damaged weapon with one from cargo, it changes to the wrench icon and repairs the item instead. a second click will swap the two repaired items.

I'm not doubting that this happened to you, just adding that it does not seem to happen all the time. maybe its just with certain items?

Davin December 22nd, 2005 07:37 AM

Re: bug alert?
I think what actually happened was that I had a cheap combat computer (the theory works with any SYST type) in there and it got damaged, I put a more advanced one into an empty hardpoint (successfully avoiding the need to click on it to swap it) and the damaged one obviously came out.

So the bug required a slightly more complex set-up than I thought, but I assure you it's there http://forum.shrapnelgames.com/images/smilies/wink.gif

What I imagine the actual cause of the crash to be is the engine attempting to repair an object that doesn't exist (the one in the empty hardpoint, instead of the one you're holding with the cursor) and throwing up as a result.
Just my two cents.

rocky8311 December 22nd, 2005 05:54 PM

Re: bug alert?
I just had my WW inexplicably close. I had a Signal Projector picked up with the cursor and I pressed the '2' key to switch over to my new Muktian Corvette and the program just...closed. No error report or anything. I'm running the new patch.

Fingers December 23rd, 2005 04:26 AM

Re: bug alert?
Davin: Interesting, sounds like you've got something there.

Rocky: Hm, that'd definitely be a bug. Does this happen reliably (like whenever you have two ships)?

rocky8311 December 23rd, 2005 02:12 PM

Re: bug alert?
It's the only time it's ever happened but I'll speak up if it does again. WW is a very nonbuggy game IMO, you should be proud.

rocky8311 December 23rd, 2005 03:09 PM

Re: bug alert?
Alright I said I would, so here I am. The same bug just happened in a different way. I was holding a Neptunium Railgun with the cursor and pressed '2' to switch from my Terran Frigate to Muktian Fighter and the game abruptly closed without any kind of Microsoft error message.

Probably a coincidence that it involved a Muktian ship both times. It's when I pressed the '2', or at least the act of switching ships.

PERHAPS it is that both times I pulled something off the Lead ship and went to put it on another without putting it down in the hold first? That is my best guess, b/c that is what I was doing both times; moving something directly between the ships while using the numbers as hotkeys.

rocky8311 December 23rd, 2005 03:11 PM

Re: bug alert?
That or maybe it crashed b/c it just didn't like me using both hotkeys and having something in the "grip" of the mouse cursor at the same time. It might have had nothing to do with me moving something directly between two ships. I'll try to replicate this.

All times are GMT -4. The time now is 05:07 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2022, Shrapnel Games, Inc. - All Rights Reserved.