.com.unity Forums
  The Official e-Store of Shrapnel Games

This Month's Specials

Bronze- Save $10.00
winSPMBT: Main Battle Tank- Save $5.00

   







Go Back   .com.unity Forums > Digital Eel > Weird Worlds: Return to Infinite Space > Scenarios and Mods

 
 
Thread Tools Display Modes
  #1  
Old October 14th, 2007, 12:17 AM

Lord_Vader Lord_Vader is offline
Private
 
Join Date: Sep 2007
Posts: 45
Thanks: 1
Thanked 2 Times in 2 Posts
Lord_Vader is on a distinguished road
Default Weird Crash

For days, no, for weeks, I've been trying to solve a most frustrating but totally odd crash on my mod.

Well, you see, I had just added in a new Tan Ru ship, and so I ran it to test it out. The first few tests I only checked out the simulator to see any faults with the ship, and everything ran smoothly. Then, one or two games later, I decided to play the actual game instead of the simulator, so I could see my new ship for real. As soon as I pressed the "Continue" button on the Lextor Mucron screen, it crashed to desktop.

I decided it must be my new Tan Ru ship, so I removed it and tried again, but the result was the same crash to desktop. I checked out the stderr file:

ERROR: audio_loadasset can't find combat/p_micmet.ogg
ERROR: audio_loadasset can't find combat/p_micmet.ogg
ERROR: audio_loadasset can't find combat/p_micmet.ogg
ERROR: audio_loadasset can't find combat/p_micmet.ogg
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Now obviously, p_micmet.ogg shouldn't actually exist, it doesn't exist in the default game, nor in any mod that I am aware of. The micrometeorite sound is a .wav not an .ogg, so I was very confused. Anyway, I decided to make a copy of the p_mdriver.ogg and then rename it to p_micmet.ogg, to see if this would fix the problem. It didn't.

When I checked out the stderr file again, it was simply:

Fatal signal: Segmentation Fault (SDL Parachute Deployed)

So, what is this? What does it even mean and WHY is the mod crashing, when I know it's no different from when it DID work quite a while ago, barring the new p_micmet.ogg (and even without that file, it still crashes anyway).

It's possible it's actually to do with Weird Worlds on it's own, or my computer, not my mod, but... default Weird Worlds and every other mod I have still work fine, and yet my mod doesn't and for apparently no reason. Or, no reason that I can think of.
  #2  
Old October 15th, 2007, 11:17 AM

sgqwonkian sgqwonkian is offline
Sergeant
 
Join Date: Aug 2007
Location: Seattle
Posts: 231
Thanks: 3
Thanked 13 Times in 10 Posts
sgqwonkian is on a distinguished road
Default Re: Weird Crash

Did you do anything in the mod that changed the micrometeorite gun at all? Is it just the default micrometeorite, or have you made any variants?

I ask because it sounds to my trial-and-error ears, like it's a problem with the weapon file, not the ship. It may even be on a variant of the weapon which doesn't appear on the ship you most recently added, but which had never spawned prior to your first crashed game.

If you've changed the wp_projmicm file at all, or made any new weapons based on the micrometeorite gun, that could be the cause of it.

I'd take a look in any related/derived wp_ files and make sure they have this line, exactly as it appears here, .wav not .ogg, etc:

SOND 100 0 combat/p_micmet.wav fire

In the default file it appears in the Projectile entry of wp_projmicm, just below the RAND line and above another SOND line. I've had several bugs/crashes that I eventually figured out had to do with lines of code being in the wrong order. None were specifically SOND lines, but it's still in the realm of possibility.
__________________
WW:RTIS & modding: http://transitivegaming.blogspot.com...abel/WW%3ARTIS
Other gaming stuff: http://transitivegaming.blogspot.com
  #3  
Old October 16th, 2007, 08:08 PM

Lord_Vader Lord_Vader is offline
Private
 
Join Date: Sep 2007
Posts: 45
Thanks: 1
Thanked 2 Times in 2 Posts
Lord_Vader is on a distinguished road
Default Still Not Working

Now, this is even weirder than before.

The "Comet Hose" weapon was linking to "p_micmet.ogg" so I changed it to "p_mdriver.ogg," a file which does exist. Since the Comet Hose is based on the Mass Driver, I simply copied the SOND line from the Mass Driver default file to the Comet Hose.

Same problem. As soon as I play the actual game (not the simulator), it crashes.

The stderr file still reads:

---------------------------------------
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
---------------------------------------

When I think about it, it surely couldn't have been anything to do with the p_micmet.ogg error, because the one and only ship which has the Comet Hose still runs completely fine in the simulator.

Regardless, that fault is fixed now and it still ain't working, so it must be something else.
  #4  
Old October 23rd, 2007, 03:52 PM
Fingers's Avatar

Fingers Fingers is offline
Sergeant
 
Join Date: Jun 2005
Posts: 341
Thanks: 0
Thanked 0 Times in 0 Posts
Fingers is on a distinguished road
Default Re: Still Not Working

Most likely the crash has nothing to do with the sound error. In general, if get an error message multiple times that means the error was survivable.

It sounds like it's crashing on creating the world. The most common world creation crashes are when placing enemy fleets (if a race is broken or there are too many fleets or some such) or initializing quests.

Are you running with the -verbose command line option? That may give you more information (although hard crashes tend to interrupt the log in unintuitive places).
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:27 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2022, Shrapnel Games, Inc. - All Rights Reserved.