.com.unity Forums
  The Official e-Store of Shrapnel Games

This Month's Specials

Approaching Infinity- Save $7.00
War Plan Pacific- Save $6.00

   







Go Back   .com.unity Forums > The Camo Workshop > WinSPWW2 > Campaigns, Scenarios & Maps
Notices


Reply
 
Thread Tools Display Modes
  #1  
Old August 2nd, 2018, 04:55 PM
zovs66's Avatar

zovs66 zovs66 is offline
Sergeant
 
Join Date: Mar 2011
Location: Ohio
Posts: 226
Thanks: 196
Thanked 92 Times in 56 Posts
zovs66 is on a distinguished road
Default Possible Scripted Campaign, Fixed Core issue

So I decided to make a linked scripted fixed core campaign based off my two Villers-Bocage scenarios.

In the scenario the A0 and B0 units have their sub-units attached as you would expect.

Before or in the actual scenario:

The A0 shows the proper assignment of two companies:


The B0 in the scenario shows the proper assignment of his 3 platoons:


After or after I added the scenario to the scripted fixed core campaign and while I am playing the game:

The A0 in the campaign, note all the sub-units are under his command:


The B0 in the campaign, note that it shows him controlling the two companies but not the platoons!:


Here is what the nodes and stuff look like in the campaign editor:


Some extra details (pics may have been good enough).

After I created the scripted campaign, and set all the values for it and each node as well as the victory conditions, when I started the campaign, I noticed that all the sub-units (B1-B3) were no longer assigned properly to the A0 or B0 formation. Hence as the player I had to go in and manually re-assign the platoon formations back to the company formation. (i.e. open up the HQ screen, show company details and cross-attach the platoons back to the HQ).

This is not what I was wanting as a the scenario and campaign designer.

The scripted campaign should have kept the sub-units (B1, B2, B3, etc) assigned to the parent company HQ unit (B0).

I also am seeing this behavior in my other fixed core campaign (Brody) and all the sub-units are messed up when you start the campaign and you have to as the player re-assign them back to the correct HQ unit.


So is this a defect, or all scripted campaign games behave this way?

Thanks Don
__________________
ASL
Reply With Quote
The Following User Says Thank You to zovs66 For This Useful Post:
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:14 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2018, Shrapnel Games, Inc. - All Rights Reserved.