.com.unity Forums
  The Official e-Store of Shrapnel Games

This Month's Specials

Armored Task Force- Save $8.00
winSPWW2- Save $5.00


Go Back   .com.unity Forums > The Camo Workshop > WinSPMBT

Thread Tools Display Modes
Old February 10th, 2015, 05:16 PM

vyrago vyrago is offline
Join Date: Jan 2008
Posts: 41
Thanks: 14
Thanked 9 Times in 7 Posts
vyrago is on a distinguished road
Default Re: Full screen problem

I had this EXACT same problem and have found a solution. Nvidia control panel has a setting for DSR (Dynamic Super Resolution) which I use in other games. I found that turning off all DSR multipliers, ie: turning OFF DSR worked. I can run SBMBT and SPWW2 at full screen again. This fix also worked for other games that I had this problem with. Give that a try and I hope this helps you out!

TL DR: ensure that all DSR multipliers are disabled in Global Settings of Nvidia Control Panel.
Reply With Quote
The Following 2 Users Say Thank You to vyrago For This Useful Post:
Old February 11th, 2015, 03:40 PM

cuckoo cuckoo is offline
Join Date: Nov 2006
Location: Finland
Posts: 27
Thanks: 2
Thanked 0 Times in 0 Posts
cuckoo is on a distinguished road
Default Re: Full screen problem

How did you come up with this!? It actually f*****g works! Thanks, man!
Reply With Quote
Old February 11th, 2015, 05:19 PM
DRG's Avatar

DRG DRG is offline
Shrapnel Fanatic
Join Date: Mar 2005
Location: GWN
Posts: 11,799
Thanks: 3,438
Thanked 5,046 Times in 2,491 Posts
DRG will become famous soon enough
Default Re: Full screen problem

I am making this a sticky thread so others with the same problem can find it easily
Reply With Quote
Old June 30th, 2016, 08:27 PM

NanbanJim NanbanJim is offline
Join Date: Jun 2016
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
NanbanJim is on a distinguished road
Default Re: Full screen issues and a solution or two

I had a slightly different issue with purchased version.

Every time I ran the game in Windowed mode with Screen/Window size as Desktop, I would get a window full width, but only (and exactly) half height.

I had locked taskbar, I had un-checked auto-hide, Borderless Gaming didn't help... I was baffled. Then I did something completely silly, using the sort of logic inspired by Vaughan's take on Alexander Pope's words: "To err is human; to really foul things up requires a computer."

I moved the perfectly-configured taskbar from monitor 1 on the left, used for my browser and chat and temperature gauges and such, to monitor 2 on the right, slightly closer to me, which I use for gaming (and thus an inappropriate place for the taskbar, given that windowed games may get confused by it, or at least may have their bottom dozen pixels covered up by said taskbar).

VOILA!! By moving the Taskbar to the same window as the game is intended to run on, it worked! Desktop sized window! Glory of glories, finally Steel Panthers covering my screen, allowing my to make war without squinting!!

As soon as the game window properly draws, I was able to unlock the taskbar, move it to the other window, and set it to auto-hide again. Also note, simply moving the "winSPWAW Game Options" window to Monitor 2 did not resolve the issue. The taskbar had to be moved to the monitor on which I expected the game to play on... even though 2 is identified by Windows as my Main Display. I can't fault any programmer here, some of this visual/display/etc API programming is like drinking a pan-galactic gargle blaster (and if you don't get that, for God's sake go read you some Hitchhiker's Guide).

So in short, in a multi-monitor setup, make sure the taskbar is locked, auto-hidden, and on the same monitor as you want to run the game on when you fire up the game! Then set it however the devil you want afterwards.

Hope this helps someone!

Last edited by NanbanJim; June 30th, 2016 at 08:33 PM.. Reason: Seriously, self? Viola? A musical instrument is NOT an appropriate exclamation!
Reply With Quote
The Following User Says Thank You to NanbanJim For This Useful Post:
Old August 29th, 2018, 08:38 PM

Grimalken Grimalken is offline
Join Date: Aug 2018
Posts: 5
Thanks: 3
Thanked 0 Times in 0 Posts
Grimalken is on a distinguished road
Default Re: Full screen issues and a solution or two

I have been playing CD version of WinSPWW2 with absolutely no problems, other than I cannot ALT+TAB while the game is running in full screen, desktop mode. I usually play at deskytop fullscreen, and when I'm selecting units to expand my core, or to start a new campaign, I'll select fullscreen and 800x600.

So I installed WinSPMBT today, installed the patches 6, 10 & 12 from here http://www.shrapnelgames.com/Camo_Wo.../MBT_page.html

I started the CD version of WinSPMBT with the exact same settings as WinSPWW2,and the game crashes immediately after the splash screen, or if disable the splash screen the game crashes almost immediately

SAL Error
IpDD->SetDisplayMode() failed, code 80004001


SAL Error
DirectDraw could not be initialized: Error code 800004001

I assumed that since WinSPWW2 worked, so would SPMBT.
Reply With Quote
Old August 29th, 2018, 09:54 PM
Mobhack's Avatar

Mobhack Mobhack is offline
National Security Advisor
Join Date: Mar 2005
Location: Dundee
Posts: 5,845
Thanks: 318
Thanked 1,768 Times in 1,160 Posts
Mobhack is on a distinguished road
Default Re: Full screen issues and a solution or two

Which is telling you that you are trying to drive the screen at a resolution your graphics card will not support. 800x600 support, as I have stated in the above posts, is not something that can be relied on by modern drivers. Perhaps you have had a driver update put in by windows updates?.

Try another, larger windows 4:3 resolution should you want to continue with full-screen modes. Perhaps 1024x768 will work?.

The 2 games should behave exactly the same since the graphics engine is the same - so if there is a difference, then something in your set-up between the 2 installations is likely to be different. You will have to find out what that is, if any. (You may have used Windows compatibility mode on the one EXE but not the other?).

If the game runs fine in windowed mode at desktop resolution - fine, that is the supported mode. As we have said before, the windowed 256 colour full-screen mode is now an unsupported mode which is only there because it's inherited from legacy DOS and early Windows 98/XP and it cannot be guaranteed to work from Windows 7 onwards.
Reply With Quote
The Following User Says Thank You to Mobhack For This Useful Post:


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 03:45 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2023, Shrapnel Games, Inc. - All Rights Reserved.